If you have added roles directly in the Engagement Portal, then Live Assist fails to synchronize user data.
Symptom
This may result in the following problems.
- You may not be able to assign licenses to your agents
- Your agents may be unable to sign in, receiving 401 Authentication Errors
Cause
You must manage your licenses and agent profiles using the Admin Portal, not the Engagement Portal. If you create additional profiles within the Engagement Portal or assign profiles to users in the Engagement Portal, it creates problems.
Solution
Review the profiles in the Engagement Portal and remove any additional roles that you have created.
Live Assist defines and requires the following profiles:
- Administrator
- Agent
- Agent Manager
- Campaign Manager
- Controller Bot (Messaging platform only)
- Survey Bot (Messaging platform only, if you have set up a post-conversation survey)
- lp-summarization-app (Messaging platform only, if customization is present)
To verify and remove additional roles from your Engagement Portal:
- Go to the Engagement Portal
- Go to Users > Profiles
- There should be 4 to 7 profiles on this page. The default configuration for our modern Messaging platform, with its 5 profiles, is shown below.
- If you have additional profiles, you must remove the profile assignment on every user:
- Go to Users > Users
- Click the filter next to Profiles and enter your erroneous profile
- For each result, Edit User and remove the Assignment
- Once the Profile has no Users, click the profile check box and click Action > Delete
Engagement Portal Default User Profile Assignments:
If you assign an Admin role to a user in the admin portal, the user will have the following profiles in the Engagement portal
If you assign a Supervisor role to a user in the admin portal, the user will have the following profiles in the Engagement portal
If the user has Agent role to a user in the admin portal, the user will have this profile in Engagement Portal
Important: You may change the user's Skills set and the Maximum number of live chats from the Engagement Portal. But for any other user details, changes should be done within Microsoft Dynamics 365 CRM. Further, roles should only be changed from Admin Portal. This is the default and the only supported way.